[6lbr-dev] 6LBR won't run on Red-IO when using NVM

Laurent Deru laurent.deru at cetic.be
Tue Jun 10 14:22:08 UTC 2014


Hi Adam,

The redwire-io NVM flasher is quite troublesome, there is no flow 
control or data verification, so if the flasher miss some data this will 
not be detected. I add -b something to the command line to improve 
reliability (it adds a delay between data). You can start at 200, but 
sometimes I have to go up to 5000 to be able to program the nvm.

Kind regards,
Laurent.

Le 9/06/14 23:42, A Renner a écrit :
> I have been trying to follow the wiki directions for getting a Red-IO 
> configured to run 6LBR.
>
> When I load the router or smartbridge into RAM, everything seems to 
> work fine. I can connect to the device and I can sniff its traffic on 
> the WSN side. When I attempt to get anything into NVM so that it will 
> persist across resets, I detect nothing.
>
> The flashing will report that the write was successful and completes 
> with the "flasher done" message, but there is no evidence that the 
> device is functioning on either the WSN side of the ethernet side.
>
> I have tried flasher images from the 6lbr repository and libmc1322x 
> and have tried compiling my own images as well as the precompiled ones 
> provided on the wiki. I have tried both the router and the smartbridge.
>
> Everything consistently works when putting the image in RAM and never 
> works when flashing to NVM.
>
> Any ideas?
>
> --Adam Renner
>
>
> _______________________________________________
> 6lbr-dev mailing list
> 6lbr-dev at lists.cetic.be
> http://lists.cetic.be/cgi-bin/mailman/listinfo/6lbr-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cetic.be/archives/6lbr-dev/attachments/20140610/bc89530c/attachment.html>


More information about the 6lbr-dev mailing list