[6lbr-dev] Help setting up 6lbr to communicate with the outside world!

Pedro Diogo pedrodiogoum at gmail.com
Thu Jun 26 19:07:21 UTC 2014


Thanks for the reply.
So, I've set CREATE_BRIDGE=0 at the .conf file and I pasted this part
(taken from /etc/6lbr/interfaces.dhcp):


>
>
>
>
>
>
>
> *auto br0iface br0 inet dhcp    pre-up brctl addbr br0    pre-up brctl
> addif br0 eth0    pre-up ip addr flush dev eth0    post-down ip link set
> eth0 down    post-down ip link set br0 down    post-down brctl delif br0
> eth0    post-down brctl delbr br0*
>

to my /etc/network/interfaces file which now looks like:

*auto lo*
>
> *iface lo inet loopback*
> *iface eth0 inet dhcp*
>
> *allow-hotplug wlan0*
> *iface wlan0 inet manual*
> *wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf*
> *iface default inet dhcp*
>
> *#Creating bridge at startup so that 6lbr attaches to it*
> *#(so i dont loose connectivity)*
> *auto br0*
> *iface br0 inet dhcp*
> *    pre-up brctl addbr br0*
> *    pre-up brctl addif br0 eth0*
> *    pre-up ip addr flush dev eth0*
> *    post-down ip link set eth0 down*
> *    post-down ip link set br0 down*
> *    post-down brctl delif br0 eth0*
> *    post-down brctl delbr br0*
>
>
> *#IPv6 tunneling trhough HE*
> *auto he-ipv6*
> *iface he-ipv6 inet6 v4tunnel*
> *    address 2001:470:1f08:aa4::2*
> *    netmask 64*
> *    endpoint 246.66.80.26*
> *    local 89.155.191.203*
> *    ttl 255*
> *    gateway 2001:470:1f08:aa4::1*
>

But it still doesn't work. I can see from the log file that 6lbr does
attaches to it because the br0 interface is bridged first to eth0 though...
I can only ping the outside world, after stopping 6lbr. Notice too that I'm
trying to use HE to provide ipv6 tunneling, and although I do get a global
ipv6, I cant reach ipv6 sites:

*pi at raspipedro:~$ ping6 ipv6.google.com <http://ipv6.google.com>*
> *PING ipv6.google.com <http://ipv6.google.com>(mad01s15-in-x05.1e100.net
> <http://mad01s15-in-x05.1e100.net>) 56 data bytes*
> *From PedroDiogo-1-pt.tunnel.tserv5.lon1.ipv6.he.net
> <http://PedroDiogo-1-pt.tunnel.tserv5.lon1.ipv6.he.net> icmp_seq=1
> Destination unreachable: Address unreachable*
>

I really don't know how to solve these issues... Any help is much
appreciated!

Best regards,
Pedro.

Pedro Diogo


On 26 June 2014 14:40, Laurent Deru <laurent.deru at cetic.be> wrote:

>  Hi,
>
> I think your two issues are linked : if 6LBR creates the internal bridge
> all the previously configured address on eth0 are lost (this is the
> expected behaviour). So what you have to do is create the bridge at startup
> and 6lbr attaches itself on it. This is done by configuring the bridge in
> /etc/network/interfaces (I see this information is missing from the faq),
> there is a example in /etc/6lbr/interfaces.dhcp.example.
>
> Kind regards,
> Laurent.
>
> Le 26/06/14 02:01, Pedro Diogo a écrit :
>
>    Hello all!
>
>  I'm very excited to use 6lbr, but I'm having some problems.
> First, my setup:
>  I have a couple of Arduinos with Xbee transmitting UDP data using CoAP to
> 6lbr (RPi). This part is working. However, there is one issue: if I fire up
> a CoAP Server on the RPi, it does not get the requests. However, if I send
> the data to a CoAP server that is installed on a host connected to RPi via
> eth (direct connection), it does get the data. So, what is the problem
> here? Why can't 6lbr route the data to itself?
>  One other issue: I don't know how to fix the connectivity lost issue
> after 6lbr starts. I've checked
> https://github.com/cetic/6lbr/wiki/FAQ#im-running-6lbr-on-a-raspberry-pi-when-6lbr-starts-up-i-loose-connectivity
> but I did not understand the fixing procedures. I did add CREATE_BRIDGE=0
> on my .conf file, but it is still not working.
>
>  Any help would be GREATLY appreciated as this project is my most
> important thing right now...
>
>  Best regards,
>   Pedro Diogo
>
>
> _______________________________________________
> 6lbr-dev mailing list6lbr-dev at lists.cetic.behttp://lists.cetic.be/cgi-bin/mailman/listinfo/6lbr-dev
>
>
>
> _______________________________________________
> 6lbr-dev mailing list
> 6lbr-dev at lists.cetic.be
> http://lists.cetic.be/cgi-bin/mailman/listinfo/6lbr-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cetic.be/archives/6lbr-dev/attachments/20140626/f0288e0f/attachment.html>


More information about the 6lbr-dev mailing list